Skrypty mi nie działają!

Ogólne pytania na temat Unity3D

Skrypty mi nie działają!

Postprzez Janke » 30 Lip 2019, 19:35

Unity 2019.2b, Windows 7

Na sam start mojej przygody z unity (I programowaniem w ogóle) obrałem sobie za cel zrobienie prostego Shoot 'em Up'a. Naciąłem się już na pierwszym skrypcie, jaki odpowiadać miał za poruszanie postacią i w sumie stoję w miejscu od dwóch tygodni. Próbowałem to zrobić na wiele sposobów, ale nic nie przynosiło efektu: Zmiana skryptu, reiportowanie projektu, zakładanie nowego projektu, nowy system input...

Powiedzieć mogę tyle, że nazwy pliku i klasy są takie same. Skrypt po prostru nie "włącza się"...
Proszę o szybką pomoc i z góry dziękuję.
Janke
 
Posty: 1
Rejestracja: 30 Lip 2019, 19:14
Has thanked: 0 time
Been thanked: 0 time

Re: Skrypty mi nie działają!

Postprzez Hostur » 30 Lip 2019, 20:14

Opisałeś co czujesz a teraz coś o problemie? :) Przeczytaj to i zastanów się co możemy wywnioskować z tego.

Mam taki test dla Ciebie. Stwórz nowy projekt, dodaj jakiś obiekt na scenę, stwórz jakiś testowy skrypt cokolwiek

Kod: Zaznacz wszystko
public class QucikTest : MonoBehaviour
{
  private void Awake() => Debug.Log("Awake!");
}


Dodaj ten skrypt na ten pusty obiekt na scenie zapisz wszystko i odpal scenę. Ten Debug z napisem Awake! musi pojawić się w logach edytora jak nie to coś pominąłeś. Zacznijmy od tego jak ten skomplikowany test nie zadziała to dojdziemy do tego o co komon :)

Edit:
Jedyne co można teraz wywnioskować z Twojego opisu to to, że skrypty które napisałeś nie istnieją na żadnym obiekcie istniejącym na scenie.
Hostur
 
Posty: 742
Rejestracja: 05 Sie 2015, 07:36
Has thanked: 0 time
Been thanked: 0 time


Wróć do Wsparcie Unity

Kto jest na forum

Użytkownicy przeglądający to forum: Brak zarejestrowanych użytkowników oraz 2 gości

cron